CaliforniaSpecial.com -- Message Boards -- 1968 California Special Limited Edition Ford Mustang GT/CS
D I S C U S S I O N . F O R U M
COMMUNITY
1968 GT/CS & HCS
2007+ GT/CS
1966-1967 HCS

Vote!

Old 09/15/2014, 06:18 PM   #1
x-codegtcs
 
x-codegtcs's Avatar
 

Location: Kaysville, UT
Joined: Sep 02
eBay: ski*beast
Posts: 549

My Garage
Brake Lights? HELP!

OK - I finally had the GTCS shipped out to North Carolina and we have been reunited. When they were unloading the car, I noticed one light bulbs not working on the brakes and the reverse lights did not come on. I thought maybe I forgot to put bulbs in the reverse lights, but they worked later when I took it for a spin.

I worked on the brake/turn signal light bulb today until it got dark and had fixed the problem. So when I was pulling into the garage, I tested the back up lights (i could see the reflection of the reverse lights on my truck) and then the brake lights went out - completely, no brake lights, no (red) driving lights - all other lights stayed on. I tried a lot of different sequences/combos with lights, reverse, no lights, brakes, etc and it seems that I can only replicate the problem when the lights are turned on. They go out, then after i release the brake for a few seconds, the driving lights come back on and I can press on the brake pedal and they come back. I am not sure that the reverse lights always need to be on to force the problem, BUT it seems to aggravate the problem.

ALL wiring is brand new AMP wire harnesses and the few custom harnesses from CoralSnake. All switches (head light, brake and reverse) are new.

I am thinking the light switch is faulty. Any suggestions where I should start and trouble shooting sequence?

Thanks! Bryce

1967 390 GTA Fastback
1968 J-Code GT/CS (Under Restoration) http://68jcodegtcs.blogspot.com/
1968 GT500 Convertible Replica
1968 X-Code GT/CS (SOLD)
x-codegtcs is offline   Reply With Quote
Old 09/16/2014, 03:59 AM   #2
dalorzo_f
My Car Details
 

Location: Brisbane Australia
Joined: Jan 06
Posts: 1,886

My Garage
IMO the most likely are switch or bad/poor ground or short.

Check around the pedal as I have seen issue there similar to those you note, intermittent issues aggravated/caused by wiring getting bumped around by the action of the pedal.

One of my two least favourite aspects of working on these cars:

1. electrical gremlins
2. anything under the dash

HTH
Unfortunately item 1 often involves item 2....

dalorzo_f is offline   Reply With Quote
Reply

  CaliforniaSpecial.com Forums > GT/CS and HCS Forums > GT/CS and HCS Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1968 - Brake light issue with lights on Ersel66 GT/CS and HCS Discussions 22 09/19/2009 10:19 AM
no brake lights zapper GT/CS and HCS Discussions 6 06/12/2007 10:29 AM
No Brake Lights case12 GT/CS and HCS Discussions 15 01/29/2006 06:43 PM
Sequential Brake Lights and Chrome CobraMan GT/CS and HCS Discussions 5 12/05/2004 05:41 PM
Flashing Brake Lights darb GT/CS and HCS Discussions 4 05/27/2003 05:58 AM


All times are GMT -7. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.


This site created, owned and maintained by Jon Hanna - Copyright 1996-2011
All rights reserved. CaliforniaSpecial.com is not affiliated with Ford Motor Company

ShowCase vBulletin Plugins by Drive Thru Online, Inc.